1. Stop wordpress updater by ftp.

As per the following post, "Wordpress needs access to your web server", you can prevent work press for asking for your ftp credentials when requesting an update.

Add the below lines to your wp.config.php file.


....
$method = 'direct';
define('FS_METHOD','direct');

/* That's all, stop editing! Happy blogging. */
...

2. Fix any issues with your (or another) plugin

There is a great plugin called "Log Deprecated Notices" that aids in Wordpress development.

Just turn change WP_DEBUG to 'true" and download the latest version from the above link. Once installed, it will be under: Tools > Deprecated Calls.

The deprecated call and line number will be displayed, along with an alternative to fix.

Note: This was only performed on a development machine. It is only recommended to do the above in a development environment.